Back-End

17 fev, 2014

O meu site quebrará se eu atualizar o WordPress?

1099 visualizações
Publicidade

Acompanho e respondo um número razoável de grupos e fóruns de WordPress como o WordPress Developers e WordPress Experts no LinkedIn. Você sabe qual é uma das perguntas mais frequentes?

“Será que o meu site irá quebrar se eu atualizar para o WordPress x.x?”

wordpress

Recentemente, respondi a esses tópicos em uma tentativa de acabar com o mito que algumas pessoas têm, que o WordPress quebrará o site durante a atualização.

 O Core

Se o seu site funciona com WordPress, você está de parabéns. Você está usando o sistema de gerenciamento de conteúdo mais popular (CMS) da interwebs, alimentando quase 20% (sic) de todos os sites.

Estou presumindo que você tem um computador pessoal ou portátil que executa Windows, Mac OS X ou alguma variação do Linux. Eu também estou supondo que a maioria de vocês tem atualizações automáticas ativadas e simplesmente deixa o sistema operacional do computador se atualizar.

E quanto a Chrome, Safari e Firefox? Você não deixa esses navegadores atualizarem automaticamente também?

É por aqui que vou.

WordPress é o sistema operacional do seu site – o core. Como todos os sistemas operacionais, exige atualizações constantes para resolver bugs, ajustes de problemas de segurança e introduzir novas funcionalidades.

Assim como qualquer sistema operacional, você precisa para mantê-lo up-to-date.

Mas irá quebrar se eu atualizar?

Sempre haverá chances de isso acontecer, então esteja preparado e certifique-se de ter um sistema de backup no lugar. Existem muitas ferramentas de backup para sites em WordPress, desde aquelas que são gratuitas e enviam e-mails com um zip dos arquivos do site e banco de dados a soluções de backup Premium, como o VaultPress, que fazem backups em tempo real.

Independentemente disso, você não deveria perguntar: “será que a atualização do WordPress irá quebrar meu site?”

Você deveria perguntar: “os temas e plugins que uso em meu site são compatíveis com a nova versão do WordPress?”

O core do WordPress, como é conhecido, é testado por centenas de desenvolvedores e milhares de beta testers antes de ser lançado como uma versão adequada e disponível como atualização. Você sabia que todas as novas versões do WordPress são aplicadas no WordPress.com antes de serem disponibilizadas no WordPress.org.?

Isso é uma série de testes em mais de 74 milhões de sites.

Se houver um erro no core do WordPress que irá “quebrar” um site, será algo muito raro no momento em que chega a você.

Assim, a minha resposta é: “Não. O WordPress não vai quebrar o seu site.”

Temas, Plugins e Apps

Continuando com a analogia dos sistemas operacionais, após a atualização, é mais provável você encontrar aquele aplicativo (ou programa – para aqueles que são das antigas) que pode não funcionar, porque é incompatível com a nova versão do sistema operacional.

*BAM* – aí está a sua resposta!

Em um site WordPress, temas e plugins são o mesmo que aplicativos em um sistema operacional. Eles rodam “em cima” do core, contando com a funcionalidade que ele proporciona.

É mais provável que, após a atualização do core do WordPress, um tema ou plugin será incompatível com a versão mais recente.

Sim, que pode “quebrar” o seu site. Mas, veja, não é a atualização do WordPress que causou o problema. É a incompatibilidade do tema ou do plugin.

Assim como aplicativos para sistemas operacionais, temas e plugins precisam ser atualizados para garantir a compatibilidade com a base em que trabalham – nesse caso, o WordPress.

O que posso fazer se meu site não funcionar após uma atualização?

Nas raras ocasiões em que isso acontece, você precisa descobrir qual tema ou plugin está causando o problema. Se você é desenvolvedor, pode ligar o modo de depuração do WordPress que deverá permiti-lo identificar o problema 98% das vezes.

Se você não for um desenvolvedor, veja esta forma simples de descobrir o que está causando o problema:

  • Desabilite todos os plugins;
  • Mude para um tema padrão do WordPress como Twenty Ten, Twenty Eleven, Twenty Twelve, Twenty Thirteen ou Twenty Fourteen;
  • Você pode ter certeza de que: o core do WordPress + tema padrão = funciona;
  • Atualize para a versão mais recente do WordPress;
  • Tente ativar o tema pela primeira vez. Se o site quebrar, você sabe que o tema é incompatível;
  • Com o tema padrão ativo, ative cada plugin, um por um, e depois de cada ativação teste o seu site para ver se ele quebrou.

Se todos os seus plugins trabalharem com o tema padrão e com a última versão do WordPress, desative-os todos novamente, ative o seu tema e teste cada plugin um por um e teste o site novamente, uma vez que poderia ser a incompatibilidade de tema e plugin.

Usando esse método você vai encontrar a combinação de core/tema/plugin que não funciona.

Quais são minhas opções se meu tema ou plugin for incompatível?

Você faz o mesmo que você faria com o seu sistema operacional.

Entre em contato com a empresa/desenvolvedor do “app” (tema/plugin), abra uma tarefa e solicite o reparo ou requeira um novo tema ou plugin que tenha a mesma funcionalidade, mas que seja compatível com o “core”.

Mantenha o WordPress atualizado

Atualizar o WordPress não quebrará o seu site. Temas e plugins incompatíveis irão.

E esta é a moral da história.

Feliz atualização!

***

Artigo traduzido pela equipe Apiki com autorização do autor. Publicado originalmente em http://www.limecanvas.com/will-my-website-break-if-i-update-wordpress/