Update do Ruby on Rails corrige vulnerabilidade

Redação iMasters em Ruby on Rails

Os desenvolvedores do Ruby on Rails lançaram as versões 3.0.1 e 2.3.10 do framework para corrigir uma vulnerabilidade que travava alguns atributos, especificamente o uso do accepts_nested_attributes_for.

O problema permitia que um invasor manipulasse formulários de entrada e fizesse mudanças arbitrárias nos registros do sistema. Os desenvolvedores alertam que todos usuários que estejam utilizando um release afetado devem realizar a atualização imediatamente.

Caso um aplicativo não utilize o accepts_nested_attributes_for ou utilize uma versão do Rails anterior à 2.3.9, ele não é afetado pelo problema. 

A versão 2.3.10 é um release regular da série 2.3 do Rails, e a 3.0.1 contém apenas uma correção de segurança. Usuários que não conseguirem atualizar imediatamente podem acessar pacotes neste link.

Com informações de H-Online

Redação iMasters em Ruby on Rails

Comentários

Dê Sua Opinião

O seu endereço de email não será publicado Campos obrigatórios são marcados *

leia mais
Este projeto é mantido e patrocinado pelas empresas:
Hospedado por: