Seções iMasters
Redes e Servidores

HDLC e PPP

Hoje veremos como configurar dois diferentes protocolos
de WAN ponto a ponto, o HDLC e o PPP. Ao final de nosso artigo,
você saberá como:

Explicar o
que o protocolo proprietário da Cisco é.
Mostrar como configurar o
HDLC em links WAN.
Explicar o protocolo aberto
PPP (Point-to-Point Protocol).
Mostrar como configurar o
PPP nas interfaces seriais.

Introdução

Uma rede onde dois roteadores estão conectados
por interfaces seriais através de um serviço alugado
de um ISP, é chamado de link ponto-a-ponto WAN. Normalmente
os roteadores estão em diferentes sites conectados via
link T1, uma fração de T1 como um link de 64K ou
outro tipo de serviço de linha alugada.

Embora dois roteadores no mesmo rack possam ser
configurados como link ponto-a-ponto, uma melhor largura de banda,
e consequentemente mais eficiência haverá, será
aproveitada se eles estiverem conectados a uma interface LAN.

Tipos de Encapsulação

Os dois tipos de encapsulação mais
populares para roteadores Cisco, utilizando linhas alugadas, são:

Point-to-Point
Protocol (PPP)
High-level Data Link Control
(HDLC)

Na maior parte dos casos, o tipo de encapsulação
que você escolher irá refletir no formato do frame
utilizado em ambos os lados do link. Se PPP, os dois lados serão
PPP. Se HDLC, os lados deverão ser HDLC.

Visão Geral Sobre o HDLC

O HDLC é o tipo de encapsulação
padrão para cada porta serial em todos os roteadores Cisco.
Isto permite apenas comunicação entre os roteadores
Cisco. Se sua WAN consite somente de roteadores Cisco, você
não deve alterar o padrão HDLC.

Monitoramento de HDLC

Utilize o comando show interface para verificar
o tipo de encapsulação de qualquer interface. Aqui,
a interface serial 0 é examinada.

O tipo de frame configurado para este roteador
é mostrado na imagem. A primeira linha da tela show interface
exibe o status da interface.

Em uma interface serial, um status “up/down” usualmente
indica um clock ruim ou uma encapsulação mal-feita.

Configurando a Encapsulação:

Utilize o comando encapsulation para modificar
o tipo de frame em qualquer interface. Aqui, neste exemplo, encapsulation
é utilizado para modificar o tipo de frame para PPP.

Partindo do princípio que HDLC é
o tipo de encapsulação padrão, o comando
encapsulation hdlc é utilizado somente quando você
quiser voltar o tipo de frame para HDLC.

Tráfego de Entrada com Sucesso:

O comando show interface verifica que a encapsulação
desta interface foi alterado para PPP.

Para esta interface torna-se operacional, o outro
ponto do link deve ter sua encapsulação modificada
para poder trabalhar corretamente.

Em um ambiente dial-up, o PPP oferece autenticação
adicional pela camada de link que o HDLC não oferece.

Link Control Protocol

O PPP inicia um controle de link valendo-se do
LCP quando uma conexão remota é estabelecida. Este
procedimento garante que o PPP está configurado em cada
um dos pontos do link.

Uma vez que a configuração está
correta, inicia-se então uma negociação de
protocolos da camada 3.

Network Control Protocols

Quando o PPP está configurado nas interfaces
seriais e o LCP torna-se operacional, cada protocolo estabelece
uma conexão única com o ponto remoto do link.

Este links lógicos são chamados de
Network Control Protocols (NCPs).

Um NCP é uma espécie de mapa de um
protocolo da camda 3, como o IP, IPX, DECnet, Vines e o AppleTalk,
em um frame da camada 2, em nosso caso o PPP.

Verificação
de LCP e NCP

Tanto o LCP e os NCPs podem ser visualizados na
tela do comando show interface. Aqui, vemos que o LCP foi configurado
e que os NCPs estão lá para o IP, IPX e AppleTalk.

O LCP é um resultado de ambos os pontos
estarem com o PPP como tipo de encapsulação. Cada
NCP é ativado por uma configuração própria
do protocolo nas interfaces seriais.

Ambiente Muilti-hardware

Agora imagine que você não tenta a
sorte de possuir uma infra totalmente Cisco. Longe de ser um desafortunado,
é comum você encontrar redes WAN na qual os roteadores
podem ser de diferentes marcas, como 3COM, Alcatel, Thomson, entre
outros.

Nestes casos uma encapsulação não
proprietária deve ser utilizada.O PPP é baseado
em padrões abertos e é suportado por qualquer roteador.

Abraços e até a próxima!

Comente também

3 Comentários

Alberto Burlamaqui

Bom dia Thiago
Se possivel, gostaria de ajuda:
Não estou conseguindo remover uma rota no Roteador Cisco, conforme descrição abaixo
ip classless
ip route 0.0.0.0 0.0.0.0 10.100.100.2
ip route 10.0.0.0 255.0.0.0 192.168.2.6
ip route 172.29.0.0 255.255.0.0 10.100.100.49
ip route 172.31.0.0 255.255.0.0 10.100.100.49
ip route 192.168.100.0 255.255.255.0 10.100.100.49 2
ip route 192.168.100.0 255.255.255.0 10.100.100.33 3
no ip http server
!
snmp-server community sanesulsede RO
snmp-server enable traps tty
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
transport input telnet
!
!
end

EUCLIDES_DA_CUNHA_0435131#

EUCLIDES_DA_CUNHA_0435131#configure t
Enter configuration commands, one per line. End with CNTL/Z.
EUCLIDES_DA_CUNHA_043(config)#no ip route 172.29.0.0 255.255.255.0 10.100.100.49
%No matching route to delete
EUCLIDES_DA_CUNHA_043(config)#

    no ip route 0.0.0.0 0.0.0.0 10.100.100.2
    no ip route 10.0.0.0 255.0.0.0 192.168.2.6
    no ip route 172.29.0.0 255.255.0.0 10.100.100.49
    no ip route 172.31.0.0 255.255.0.0 10.100.100.49
    no ip route 192.168.100.0 255.255.255.0 10.100.100.49 2
    no ip route 192.168.100.0 255.255.255.0 10.100.100.33 3

    Exclui todas as rotas

Alex Casanas

Ambos são muti utilizados

Alex casanas

Qual a sua opinião?